Quantcast

Apfelwein ?'s

Wine Making Talk

Help Support Wine Making Talk:

sly22guy

Senior Member
Joined
Jan 4, 2010
Messages
604
Reaction score
0
My apfelwein (ed's Recipe) just checked it today tastes good, still not too clear yet (6 weeks) check the sg and it came out to about 1.3!?
is this even possible, im kinda confused here does this mean it did not finish fermenting? What can i do to fix it?
 
Last edited:

IQwine

Semi-Obsessed
Joined
Mar 4, 2009
Messages
412
Reaction score
0
a few questions....

what was starting SG?
did you record any SG's along the way?
what was the temp?

this info will help us help you
 

sly22guy

Senior Member
Joined
Jan 4, 2010
Messages
604
Reaction score
0
temp stays right around 70. I dont have the starting sg with me but as i recall it was about 1.1. would it hurt if i got another pack of yeast?
 

IQwine

Semi-Obsessed
Joined
Mar 4, 2009
Messages
412
Reaction score
0
SG of 1.100 is high for this.
and SG now of 1.300 does not make sense.

what was the recipe? and how did U make it?
when did U start this?
did U see airlock activity along the way?
 

sly22guy

Senior Member
Joined
Jan 4, 2010
Messages
604
Reaction score
0
just checked for some reason i dont have the starting sg written down. anyhow. it smells good and tastes decent just seems like maybe the fermentation stalled?
 

Goodfella

Senior Member
Joined
Dec 7, 2008
Messages
1,514
Reaction score
1
Are you sure the SG doesn't read 1.003.... instead of 1.3 mentioned above?
 

sly22guy

Senior Member
Joined
Jan 4, 2010
Messages
604
Reaction score
0
I'll check it again tomorrow to make sure. but im sure it said 1.3, cause it was sticking way out the test tube.

I started it 6 weeks ago, bubbled like crazy for a while, had to change out the airlock because it got some up in it. its ed's recipe on here and i followed it to the t. used same sugar & wine yeast.
 
Last edited:

cpfan

Senior Member
Joined
Nov 5, 2006
Messages
4,867
Reaction score
193
I'll check it again tomorrow to make sure. but im sure it said 1.3, cause it was sticking way out the test tube.
Please use three decimal places when reporting your sg readings. 1.3 probably means 1.003 or maybe 1.030. Very few hydrometers can measure 1.300. Advice for 1.003 vs 1.030 is very different.

Steve
 

sly22guy

Senior Member
Joined
Jan 4, 2010
Messages
604
Reaction score
0
I think that my problem was that there were alot of bubbles in my test tube and it gave me a false reading i tapped on the test tube and it comes down to 1.0. Should i degas this & should i add Potassium sorbate before i bottle? or should i just degas & bottle?
 

Latest posts

Top