Mosti Mondiale Mosti Shiraz

Winemaking Talk - Winemaking Forum

Help Support Winemaking Talk - Winemaking Forum:

jnblk

Junior
Joined
Oct 7, 2009
Messages
16
Reaction score
0
I have a Mosti Shiraz in a 6 gallon carboy, 1st racking, the instructions call for a second racking approx 1 week after the first rack, when the SG is between .992 to .999., I checked the SG last night it was at 1.000, it was the same 5 days ago. I moved the juice to the basement at the first racking and I'm thinking the temp is to cool for complete fermentation....
What should I do??:?
 

rawlus

Senior Member
Joined
Oct 3, 2009
Messages
349
Reaction score
2
what is the temp of the juice in the basement?
what was the starting SG?
.999 is very close to 1.000... is the sample you're reading clear of debris? are you reading at below the meniscus?
if you can get the juice in the 70's maybe you'll get a little more ferment out of it..or it might be done.
 

jnblk

Junior
Joined
Oct 7, 2009
Messages
16
Reaction score
0
The basement is about 64 degf. I can not remember the starting SG. I have it written at home... I agree that the 1.00 reading is close and the sample was clear as a bell, tasted good but a bit fizzy. I'm reading correctly at the botom of the meniscus. I thought about warming the juice but don't want to ruin it???? Will warming ruin it....?
 

mmadmikes1

smart @$$
Joined
Aug 18, 2009
Messages
1,897
Reaction score
88
64 is probably to cool. I would take it back up staird and warm it up, once the fermentaion startd again rack it. I would want it lower than that before I considered it done.
 

Wade E

Premium
Joined
Jul 3, 2006
Messages
33,224
Reaction score
279
Yep warm it up really good and stir it up to get the yeast some 02 and hopefully that will revive them. Never bring down the temp until fermemtation is done and your wine is degassed.
 

jnblk

Junior
Joined
Oct 7, 2009
Messages
16
Reaction score
0
Dreaded Rotten Egg Smell

Ok, I managed to get fermentation started again but a few days later I took a wiff and the juice had a rotten egg smell. I quickly did a couple spread out rackings and on the last added 1/4 teaspoon of potassium metabisulfite, SG at .998. It has been about a week and I believe the smell has gone away, what do I do now??????
 

Wade E

Premium
Joined
Jul 3, 2006
Messages
33,224
Reaction score
279
I belive now you would add the sorbate if you havent already and then the fining agent. I dont have the Mosti Instructions in front of me but just follow them as if you have just finished fermentation.
 

Latest posts

Top